1. 软件迷首页
  2. 网站
  3. 建站技巧

纯代码禁用Gutenberg(古腾堡) 编辑器 回归经典的Classic Editor编辑器

现在很多站长对wordpress高版本吐槽最多的一点就是所谓Gutenberg编辑器,Gutenberg编辑器是5.0及以上的版本默认的编辑器。

Gutenberg编辑器优点很多,但是槽点也不少,至少我本人用了之后感觉没有之前的Classic Editor编辑器简单易用。

其实网上有很多方法和教程教大家怎么回到Classic Editor编辑器,比如安装插件之类的。

但是能用代码解决的,何必用插件呢?

上代码,在主题模板functions.php文件中加上以下两行代码,轻松切回Classic Editor编辑器。

add_filter('use_block_editor_for_post', '__return_false'); 
remove_action( 'wp_enqueue_scripts', 'wp_common_block_scripts_and_styles' );

Classic Editor编辑器目前还没被删除,至于在哪个wordpress版本删除,就不得而知了。

原创文章,作者:风尘,如若转载,请注明出处:https://rjmi.net/54.html

发表评论

电子邮件地址不会被公开。 必填项已用*标注